December 13th, 2015

404

DF'ное

Интуиция мне подсказывает, что версия 0.42 - это не спроста. Алсо, оно вышло с первым комплектом багфиксов, и это первая версия, которую я ща буду щупать (из 0.42, конечно).

Ага, не буду, ибо ад и писец по зависимостям.

df хочет libgtk2.0-0:i386, который хочет libcups2:i386, который хочет libgnutls-deb0-28:i386, который хочет libnettle4 (>= 2.7).

Libnettle4 сам хочет только libc, а вот его хочет много кто (35 шт).

При попытке её установить:
The following packages have unmet dependencies:
libcurl3-gnutls : Depends: librtmp1 (>= 2.4+20131018.git79459a2-3~) but it is not going to be installed
libgnutls-deb0-28 : Conflicts: libnettle4 but 2.7.1-5 is to be installed

Получается циклическое love-hate: libgnutls-deb0-28:i386 depends: libnettle4, но при этом Conflicts: libnettle4

Аптитьюд тоже считает так:

i A libgnutls-deb0-28 Conflicts libnettle4

А я не понимаю почему.

Смотрим на libgnutls-deb0-28:
Ага, x86_64 установлена и всё хорошо, а i386 не хочет ставиться...

libgnutls-deb0-28:
Installed: 3.3.18-1
Candidate: 3.3.18-1
Version table:
*** 3.3.18-1 500
500 http://ftp.it.debian.org/debian sid/main amd64 Packages

libgnutls-deb0-28:i386:
Installed: (none)
Candidate: 3.3.19-1
Version table:
3.3.19-1 500
500 http://ftp.it.debian.org/debian sid/main i386 Packages

Вот и ответ "почему". Потому что в репозиториях почему-то разные версии i386 и x86_64 версий.

Вот тебе бабка и мультиарч.

... однако, современная инфраструктура к подобной порнографии готова: http://snapshot.debian.org/package/gnutls28/3.3.18-1/#libgnutls-deb0-28_3.3.18-1
Устанавливаем http://snapshot.debian.org/archive/debian/20150930T213602Z/pool/main/g/gnutls28/libgnutls-deb0-28_3.3.18-1_i386.deb

после этого всё остальное устанавливается и гномики готовы умирать во славу славы.