?

Log in

No account? Create an account
Previous Entry Share Next Entry
Резервирование через двух провайдеров (циско)
404
amarao_san
Итак, я решил проблему (почти).

Суть: два провайдера. Три порта. Один в локалку, по одному на провайдера.

Требуется: резервирование канала в интернет (исходящий трафик, входящий, кроме www).

Идея решения: SLA, route-map NAT.

Вот конфигурация (лишние ACL'ы опущены, NAT показан на примере 25ого порта, остальные аналогично):

100.1.1.99 - сеть первого провайдера (100.1.1.98 - гейт, 100.1.1.66 - бордвей гейтвей в сети ISP №1, который мы проверяем на живость)
200.2.2.2 - сеть второго провайдера (200.2.2.1 - гейт)

ip sla monitor schedule 1 life forever start-time now
ip sla monitor 123
 type echo protocol ipIcmpEcho 100.1.1.66
 timeout 2000
 threshold 300
 frequency 2


interface FastEthernet0/0
 description Local
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
!
interface FastEthernet0/1
 description Ext-ISP1
 ip address 100.1.1.99 255.0.0.0
 ip nat outside

interface FastEthernet0/2
 description Ext-ISP2
 ip address 200.2.2.2 255.255.255.248
 ip nat outside

ip local policy route-map ISPCHECK
ip route 0.0.0.0 0.0.0.0 100.1.1.98 track 123
ip route 0.0.0.0 0.0.0.0 200.2.2.1 200

ip nat translation tcp-timeout 15
ip nat translation udp-timeout 15
ip nat translation finrst-timeout 10
ip nat translation syn-timeout 30
ip nat translation icmp-timeout 10

ip nat inside source route-map ISP1 interface FastEthernet0/1 overload
ip nat inside source route-map ISP2 interface FastEthernet0/1 overload
ip nat inside source static tcp 192.168.1.2 25 200.2.2.2 25 extendable
ip nat inside source static tcp 192.168.1.2 25 100.1.1.99 25 extendable

route-map ISPCHECK permit 10
 match ip address 101
 set interface FastEthernet0/1
!
route-map ISP1 permit 10
 match ip address NAT
 match interface FastEthernet0/1
!
route-map ISP2 permit 10
 match ip address NAT
 match interface FastEthernet0/2

ip access list extended NAT
 permit 192.168.0.0 0.0.255.255 any 

access-list 101 permit icmp any host 100.1.1.66 echo


Остался не решённым вопрос с лагами при переходе с одной линии на другую - пока nat translation table не почистится, идут былинные отказы. Вроде, от балды вписал таймауты, посмотрим, не вызовет ли это каких-то где-то глюков...

PS Пишу через резервную линию, т.к.
int f0/1
sh

  • 1
а как железко называеццо? в смысле номер?

обычный иос, который adv k9. А вообще, Cisco 1841

  • 1